CVE-2025-28164
CVE-2025-28164
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Buffer Overflow vulnerability in libpng 1.6.43-1.6.46 allows a local attacker to cause a denial of service via png_create_read_struct() function.
CVSS 5.5 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libpng1.6 Debian:12
- Versions
- 1.6.39-2
- 1.6.39-2+deb12u1
- 1.6.39-2+deb12u2
- 1.6.39-2+deb12u3
- 1.6.39-2+deb12u4
- 1.6.39-2+deb12u5
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.41-1
- 1.6.42-1
- 1.6.42-1.1~exp1
- 1.6.43-1
- 1.6.43-1exp1
- 1.6.43-2
- 1.6.43-3
- 1.6.43-4
- 1.6.43-5
- 1.6.44-1
- 1.6.44-2
- 1.6.44-3
- 1.6.45-1
- 1.6.46-1
- 1.6.46-2
- 1.6.46-3
- 1.6.46-4
- 1.6.47-1
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- 1.6.51-1
- 1.6.52-1
- 1.6.53-1
- 1.6.54-1
- 1.6.55-1
- 1.6.56-1
- 1.6.57-1
- 1.6.58-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libpng1.6 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.6.47-1
Update to 1.6.47-1
libpng1.6 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.6.47-1
Update to 1.6.47-1
libpng1.6 Ubuntu:24.04:LTS
- Versions
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- 1.6.43-5ubuntu0.1
- 1.6.43-5ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 1.6.43-5ubuntu0.4
Update to 1.6.43-5ubuntu0.4