p PatchFirst

CVE-2025-2937

CVE-2025-2937 · Inefficient Regular Expression Complexity in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 13.2 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed authenticated users to create a denial of service condition by sending specially crafted markdown payloads to the Wiki feature.

CVSS 6.5 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 13.2, < 18.0.6: Affected (semver)
    • ≥ 18.1, < 18.1.4: Affected (semver)
    • ≥ 18.2, < 18.2.2: Affected (semver)

    Update to 18.0.6; Update to 18.1.4; Update to 18.2.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →