p PatchFirst

CVE-2025-2938

CVE-2025-2938 · Business Logic Errors in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 17.3 before 17.11.5, 18.0 before 18.0.3, and 18.1 before 18.1.1 that could have allowed authenticated users to gain elevated project privileges by requesting access to projects where role modifications during the approval process resulted in unintended permission grants.

CVSS 3.1 · Low · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 17.3, < 17.11.5: Affected (semver)
    • ≥ 18.0, < 18.0.3: Affected (semver)
    • ≥ 18.1, < 18.1.1: Affected (semver)

    Update to 17.11.5; Update to 18.0.3; Update to 18.1.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →