p PatchFirst

CVE-2025-29606

CVE-2025-29606

This page contains facts from public vulnerability sources. Check the original advisory before updating.

py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.

CVSS 4.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • py-libp2p

    Versions
    • ≥ 0, < 0.2.3: Affected (semver)

    Update to 0.2.3

  • libp2p PyPI

    Versions
    • 0.1.0a0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.2.0
    • 0.2.1
    • 0.2.2
    Affected ranges
    • ECOSYSTEM: < 0.2.3

    Update to 0.2.3

Original sources

Check your server →