CVE-2025-29771
CVE-2025-29771 · HtmlSanitizer vulnerable to XSS when used with contentEditable
This page contains facts from public vulnerability sources. Check the original advisory before updating.
HtmlSanitizer is a client-side HTML Sanitizer. Versions prior to 2.0.3 have a cross-site scripting vulnerability when the sanitizer is used with a `contentEditable` element to set the elements `innerHTML` to a sanitized string produced by the package. If the code is particularly crafted to abuse the code beautifier, that runs AFTER sanitation. The issue is patched in version 2.0.3.
CVSS 5.3 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
htmlsanitizer
- Versions
- < 2.0.3: Affected
No fix published
@jitbit/htmlsanitizer npm
- Affected ranges
- SEMVER: < 2.0.3
Update to 2.0.3