p PatchFirst

CVE-2025-30159

CVE-2025-30159 · Kirby vulnerable to path traversal of snippet names in the `snippet()` helper

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby sites that use the `snippet()` helper or `$kirby->snippet()` method with a dynamic snippet name (such as a snippet name that depends on request or user data). Sites that only use fixed calls to the `snippet()` helper/`$kirby->snippet()` method (i.e. calls with a simple string for the snippet name) are *not* affected. A missing path traversal check allowed attackers to navigate and access all files on the server that were accessible to the PHP process, including files outside of the snippets root or even outside of the Kirby installation. PHP code within such files was executed. Such attacks first require an attack vector in the site code that is caused by dynamic snippet names, such as `snippet('tags-' . get('tags'))`. It generally also requires knowledge of the site structure and the server's file system by the attacker, although it can be possible to find vulnerable setups through automated methods such as fuzzing. In a vulnerable setup, this could cause damage to the confidentiality and integrity of the server. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, Kirby maintainers have added a check for the snippet path that ensures that the resulting path is contained within the configured snippets root. Snippet paths that point outside of the snippets root will not be loaded.

CVSS 6.3 · Medium · EPSS 0.7% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • kirby

    Versions
    • < 3.9.8.3: Affected
    • >= 3.10.0, < 3.10.1.2: Affected
    • >= 4.0.0, < 4.7.1: Affected

    No fix published

  • getkirby/kirby Packagist

    Versions
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.5.0
    • 2.5.1
    • 2.5.10
    • 2.5.11
    • 2.5.11-RC-1
    • 2.5.12
    • 2.5.13
    • 2.5.14
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    • 2.5.5-RC-1
    • 2.5.6
    • 2.5.6-RC-1
    • 2.5.7
    • 2.5.7-RC-1
    • 2.5.8
    • 2.5.8-RC-1
    • 2.5.9
    • 2.5.9-RC-1
    • 2.5.9-RC-2
    Affected ranges
    • ECOSYSTEM: < 3.9.8.3

    Update to 3.9.8.3

  • getkirby/kirby Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 3.10.0, < 3.10.1.2

    Update to 3.10.1.2

  • getkirby/kirby Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 4.0.0, < 4.7.1

    Update to 4.7.1

Original sources

Check your server →