p PatchFirst

CVE-2025-30219

CVE-2025-30219 · RabbitMQ has XSS Vulnerability in an Error Message in Management UI

This page contains facts from public vulnerability sources. Check the original advisory before updating.

RabbitMQ is a messaging and streaming broker. Versions prior to 4.0.3 are vulnerable to a sophisticated attack that could modify virtual host name on disk and then make it unrecoverable (with other on disk file modifications) can lead to arbitrary JavaScript code execution in the browsers of management UI users. When a virtual host on a RabbitMQ node fails to start, recent versions will display an error message (a notification) in the management UI. The error message includes virtual host name, which was not escaped prior to open source RabbitMQ 4.0.3 and Tanzu RabbitMQ 4.0.3, 3.13.8. An attack that both makes a virtual host fail to start and creates a new virtual host name with an XSS code snippet or changes the name of an existing virtual host on disk could trigger arbitrary JavaScript code execution in the management UI (the user's browser). Open source RabbitMQ `4.0.3` and Tanzu RabbitMQ `4.0.3` and `3.13.8` patch the issue.

CVSS 6.1 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: system · database

Affected products and versions

  • rabbitmq

    Versions
    • < 4.0.3: Affected

    No fix published

  • rabbitmq-server Debian:12

    Versions
    • 3.10.8-1.1
    • 3.10.8-1.1+deb12u1
    • 3.10.8-2
    • 3.10.8-3
    • 3.10.8-4
    • 3.12.1-1
    • 3.12.1-1.1
    • 4.0.5-1
    • 4.0.5-10
    • 4.0.5-11
    • 4.0.5-12
    • 4.0.5-13
    • 4.0.5-14
    • 4.0.5-2
    • 4.0.5-3
    • 4.0.5-4
    • 4.0.5-5
    • 4.0.5-6
    • 4.0.5-8
    • 4.0.5-9
    • 4.3.0-1
    • 4.3.0-2
    • 4.3.0-3
    • 4.3.2-1
    • 4.3.2-2
    • 4.3.2-3
    • 4.3.2-4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • rabbitmq-server Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.0.5-1

    Update to 4.0.5-1

  • rabbitmq-server Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.0.5-1

    Update to 4.0.5-1

  • rabbitmq-server Ubuntu:20.04:LTS

    Versions
    • 3.7.8-4ubuntu2
    • 3.7.18-1
    • 3.8.2-0ubuntu1
    • 3.8.2-0ubuntu1.1
    • 3.8.2-0ubuntu1.2
    • 3.8.2-0ubuntu1.3
    • 3.8.2-0ubuntu1.4
    • 3.8.2-0ubuntu1.5
    • 3.8.3-0ubuntu0.1
    • 3.8.3-0ubuntu0.2
    Affected ranges
    • ECOSYSTEM: < 3.8.3-0ubuntu0.3

    Update to 3.8.3-0ubuntu0.3

  • rabbitmq-server Ubuntu:22.04:LTS

    Versions
    • 3.8.9-3ubuntu1
    • 3.9.8-1
    • 3.9.8-2
    • 3.9.8-3
    • 3.9.8-5
    • 3.9.8-6
    • 3.9.13-1
    • 3.9.13-1ubuntu0.22.04.1
    • 3.9.13-1ubuntu0.22.04.2
    • 3.9.27-0ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 3.9.27-0ubuntu0.2

    Update to 3.9.27-0ubuntu0.2

  • rabbitmq-server Ubuntu:24.04:LTS

    Versions
    • 3.12.1-1
    • 3.12.1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 3.12.1-1ubuntu1.2

    Update to 3.12.1-1ubuntu1.2

Original sources

Check your server →