CVE-2025-30258
CVE-2025-30258
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In GnuPG before 2.5.5, if a user chooses to import a certificate with certain crafted subkey data that lacks a valid backsig or that has incorrect usage flags, the user loses the ability to verify signatures made from certain other signing keys, aka a "verification DoS."
CVSS 2.7 · Low · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gnupg
- Versions
- ≥ 0, < 2.5.5: Affected (semver)
Update to 2.5.5
gnupg2 Debian:12
- Versions
- 2.2.40-1.1
- 2.2.40-1.1+deb12u1
- 2.2.40-1.1+deb12u2
- 2.2.40-1.1+hurd.1
- 2.2.40-1.1+loong64
- 2.2.40-2
- 2.2.40-3
- 2.2.43-1
- 2.2.43-2
- 2.2.43-3
- 2.2.43-4
- 2.2.43-5
- 2.2.43-6
- 2.2.43-7
- 2.2.43-8
- 2.2.44-1
- 2.2.45-1
- 2.2.45-2
- 2.2.45-3
- 2.2.46-1
- 2.2.46-2
- 2.2.46-3
- 2.2.46-4
- 2.2.46-5
- 2.2.46-6
- 2.2.46~pre1-1
- 2.3.1-1
- 2.4.3-2
- 2.4.4-1
- 2.4.4-2
- 2.4.4-3
- 2.4.4-4
- 2.4.5-1
- 2.4.5-2
- 2.4.5-3
- 2.4.6-1
- 2.4.7-1
- 2.4.7-10
- 2.4.7-11
- 2.4.7-12
- 2.4.7-13
- 2.4.7-14
- 2.4.7-15
- 2.4.7-16
- 2.4.7-17
- 2.4.7-18
- 2.4.7-19
- 2.4.7-2
- 2.4.7-20
- 2.4.7-21
- 2.4.7-3
- 2.4.7-4
- 2.4.7-5
- 2.4.7-6
- 2.4.7-7
- 2.4.7-8
- 2.4.7-9
- 2.4.8-1
- 2.4.8-2
- 2.4.8-3
- 2.4.8-4
- 2.4.8-5
- 2.4.8-6
- 2.4.9-1
- 2.4.9-2
- 2.4.9-3
- 2.4.9-4
- 2.4.9-5
- 2.4.9-6
- 2.4.9-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gnupg2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.2.46-5
Update to 2.2.46-5
gnupg2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.2.46-5
Update to 2.2.46-5
gnupg2 Ubuntu:Pro:16.04:LTS
- Versions
- 2.0.28-3ubuntu1
- 2.0.28-3ubuntu2
- 2.1.11-6ubuntu1
- 2.1.11-6ubuntu2
- 2.1.11-6ubuntu2.1
- 2.1.11-6ubuntu2.1+esm1
- Affected ranges
- ECOSYSTEM: < 2.1.11-6ubuntu2.1+esm2
Update to 2.1.11-6ubuntu2.1+esm2
gnupg2 Ubuntu:Pro:18.04:LTS
- Versions
- 2.1.15-1ubuntu8
- 2.2.4-1ubuntu1
- 2.2.4-1ubuntu1.1
- 2.2.4-1ubuntu1.2
- 2.2.4-1ubuntu1.3
- 2.2.4-1ubuntu1.4
- 2.2.4-1ubuntu1.5
- 2.2.4-1ubuntu1.6
- Affected ranges
- ECOSYSTEM: < 2.2.4-1ubuntu1.6+esm1
Update to 2.2.4-1ubuntu1.6+esm1
gnupg2 Ubuntu:20.04:LTS
- Versions
- 2.2.12-1ubuntu3
- 2.2.17-3ubuntu1
- 2.2.19-3ubuntu2
- 2.2.19-3ubuntu2.1
- 2.2.19-3ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 2.2.19-3ubuntu2.4
Update to 2.2.19-3ubuntu2.4
gnupg2 Ubuntu:22.04:LTS
- Versions
- 2.2.20-1ubuntu4
- 2.2.27-2ubuntu1
- 2.2.27-3ubuntu1
- 2.2.27-3ubuntu2
- 2.2.27-3ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 2.2.27-3ubuntu2.3
Update to 2.2.27-3ubuntu2.3
gnupg2 Ubuntu:24.04:LTS
- Versions
- 2.2.40-1.1ubuntu1
- 2.4.4-2ubuntu7
- 2.4.4-2ubuntu15
- 2.4.4-2ubuntu16
- 2.4.4-2ubuntu17
- Affected ranges
- ECOSYSTEM: < 2.4.4-2ubuntu17.2
Update to 2.4.4-2ubuntu17.2
gnupg2 Ubuntu:25.10
- Affected ranges
- ECOSYSTEM: < 2.4.4-2ubuntu23
Update to 2.4.4-2ubuntu23