p PatchFirst

CVE-2025-30402

CVE-2025-30402

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A heap-buffer-overflow vulnerability in the loading of ExecuTorch methods can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit 93b1a0c15f7eda49b2bc46b5b4c49557b4e9810f

CVSS 8.1 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • executorch

    Versions
    • ≥ 0, < https://github.com/pytorch/executorch/commit/93b1a0c15f7eda49b2bc46b5b4c49557b4e9810f: Affected (git)

    No fix published

  • executorch PyPI

    Versions
    • 0.1.0
    • 0.1.2
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.6.0
    Affected ranges
    • ECOSYSTEM: < 0.7.0

    Update to 0.7.0

  • org.pytorch:executorch-android Maven

    Versions
    • 0.5.0
    • 0.5.1
    • 0.6.0
    • 0.6.0-rc1
    • 0.6.0-rc3
    • 0.6.0-rc4
    • 0.6.0-rc6
    Affected ranges
    • ECOSYSTEM: < 0.7.0-rc1

    Update to 0.7.0-rc1

  • github.com/pytorch/executorch SwiftURL

    Affected ranges
    • SEMVER: < 0.7.0-rc1

    Update to 0.7.0-rc1

Original sources

Check your server →