p PatchFirst

CVE-2025-3108

CVE-2025-3108 · Unsafe Deserialization in JsonPickleSerializer Enables Remote Code Execution in run-llama/llama_index

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A critical deserialization vulnerability exists in the run-llama/llama_index library's JsonPickleSerializer component, affecting versions v0.12.27 through v0.12.40. This vulnerability allows remote code execution due to an insecure fallback to Python's pickle module. JsonPickleSerializer prioritizes deserialization using pickle.loads(), which can execute arbitrary code when processing untrusted data. Attackers can exploit this by crafting malicious payloads to achieve full system compromise. The root cause includes an insecure fallback mechanism, lack of validation or safeguards, misleading design, and violation of Python security guidelines.

CVSS 5.0 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • run-llama/llama_index

    Versions
    • ≥ unspecified, < v0.12.41: Affected (custom)

    Update to v0.12.41

  • llama-index-core PyPI

    Versions
    • 0.11.15
    • 0.11.16
    • 0.11.17
    • 0.11.18
    • 0.11.19
    • 0.11.20
    • 0.11.21
    • 0.11.22
    • 0.11.23
    • 0.12.0
    • 0.12.1
    • 0.12.10
    • 0.12.10.post1
    • 0.12.11
    • 0.12.12
    • 0.12.13
    • 0.12.14
    • 0.12.15
    • 0.12.16
    • 0.12.16.post1
    • 0.12.17
    • 0.12.18
    • 0.12.19
    • 0.12.2
    • 0.12.20
    • 0.12.21
    • 0.12.22
    • 0.12.23
    • 0.12.23.post1
    • 0.12.23.post2
    • 0.12.24
    • 0.12.24.post1
    • 0.12.25
    • 0.12.26
    • 0.12.27
    • 0.12.27a1
    • 0.12.27a2
    • 0.12.27a3
    • 0.12.28
    • 0.12.29
    • 0.12.3
    • 0.12.30
    • 0.12.31
    • 0.12.32
    • 0.12.33
    • 0.12.33.post1
    • 0.12.34
    • 0.12.34.post1
    • 0.12.34a1
    • 0.12.34a2
    • 0.12.34a3
    • 0.12.34a4
    • 0.12.34a5
    • 0.12.35
    • 0.12.36
    • 0.12.37
    • 0.12.38
    • 0.12.39
    • 0.12.4
    • 0.12.40
    • 0.12.5
    • 0.12.6
    • 0.12.7
    • 0.12.8
    • 0.12.9
    Affected ranges
    • ECOSYSTEM: ≥ 0.11.15, < 0.12.41

    Update to 0.12.41

  • llama-index PyPI

    Versions
    • 0.12.27
    • 0.12.28
    • 0.12.29
    • 0.12.30
    • 0.12.31
    • 0.12.32
    • 0.12.33
    • 0.12.34
    • 0.12.35
    • 0.12.36
    • 0.12.37
    • 0.12.38
    • 0.12.39
    • 0.12.40
    Affected ranges
    • ECOSYSTEM: ≥ 0.12.27, < 0.12.41

    Update to 0.12.41

Original sources

Check your server →