CVE-2025-31682
CVE-2025-31682 · Google Tag - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-011
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS).This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.
CVSS 4.8 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
google tag
- Versions
- ≥ 0.0.0, < 1.8.0: Affected (semver)
- ≥ 2.0.0, < 2.0.8: Affected (semver)
Update to 1.8.0; Update to 2.0.8
drupal/google_tag Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: < 1.8.0
- ECOSYSTEM: ≥ 2.0.0, < 2.0.8
Update to 1.8.0; Update to 2.0.8
drupal/google_tag Packagist
- Affected ranges
- ECOSYSTEM: < 1.8.0
Update to 1.8.0
drupal/google_tag Packagist
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.0.8
Update to 2.0.8