CVE-2025-31687
CVE-2025-31687 · SpamSpan filter - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-016
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal SpamSpan filter allows Cross-Site Scripting (XSS).This issue affects SpamSpan filter: from 0.0.0 before 3.2.1.
CVSS 6.1 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
spamspan filter
- Versions
- ≥ 0.0.0, < 3.2.1: Affected (semver)
Update to 3.2.1
drupal/spamspan Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: < 3.2.1
Update to 3.2.1
drupal/spamspan Packagist
- Affected ranges
- ECOSYSTEM: < 3.2.1
Update to 3.2.1