p PatchFirst

CVE-2025-31689

CVE-2025-31689 · General Data Protection Regulation - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-018

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-Site Request Forgery (CSRF) vulnerability in Drupal General Data Protection Regulation allows Cross Site Request Forgery.This issue affects General Data Protection Regulation: from 0.0.0 before 3.0.1, from 3.1.0 before 3.1.2.

CVSS 8.1 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • general data protection regulation

    Versions
    • ≥ 0.0.0, < 3.0.1: Affected (semver)
    • ≥ 3.1.0, < 3.1.2: Affected (semver)

    Update to 3.0.1; Update to 3.1.2

  • drupal/gdpr Packagist:https://packages.drupal.org/8

    Affected ranges
    • ECOSYSTEM: < 3.0.1
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.2

    Update to 3.0.1; Update to 3.1.2

  • drupal/gdpr Packagist

    Affected ranges
    • ECOSYSTEM: < 3.0.1

    Update to 3.0.1

  • drupal/gdpr Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.2

    Update to 3.1.2

Original sources

Check your server →