CVE-2025-31691
CVE-2025-31691 · OAuth2 Server - Moderately critical - Access bypass - SA-CONTRIB-2025-020
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Missing Authorization vulnerability in Drupal OAuth2 Server allows Forceful Browsing.This issue affects OAuth2 Server: from 0.0.0 before 2.1.0.
CVSS 9.8 · Critical · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
oauth2 server
- Versions
- ≥ 0.0.0, < 2.1.0: Affected (semver)
Update to 2.1.0
drupal/oauth2_server Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: < 2.1.0
Update to 2.1.0
drupal/oauth2_server Packagist
- Affected ranges
- ECOSYSTEM: < 2.1.0
Update to 2.1.0