p PatchFirst

CVE-2025-31694

CVE-2025-31694 · Two-factor Authentication (TFA) - Moderately critical - Access bypass - SA-CONTRIB-2025-023

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Incorrect Authorization vulnerability in Drupal Two-factor Authentication (TFA) allows Forceful Browsing.This issue affects Two-factor Authentication (TFA): from 0.0.0 before 1.10.0.

CVSS 8.1 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • two-factor authentication (tfa)

    Versions
    • ≥ 0.0.0, < 1.10.0: Affected (semver)

    Update to 1.10.0

  • drupal/tfa Packagist:https://packages.drupal.org/8

    Affected ranges
    • ECOSYSTEM: < 1.10.0

    Update to 1.10.0

  • drupal/tfa Packagist

    Affected ranges
    • ECOSYSTEM: < 1.10.0

    Update to 1.10.0

Original sources

Check your server →