CVE-2025-3193
CVE-2025-3193
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the package algoliasearch-helper from 2.0.0-rc1 and before 3.11.2 are vulnerable to Prototype Pollution in the _merge() function in merge.js, which allows constructor.prototype to be written even though doing so throws an error. In the "extreme edge-case" that the resulting error is caught, code injected into the user-supplied search parameter may be exeucted. This is related to but distinct from the issue reported in [CVE-2021-23433](https://security.snyk.io/vuln/SNYK-JS-ALGOLIASEARCHHELPER-1570421). **NOTE:** This vulnerability is not exploitable in the default configuration of InstantSearch since searchParameters are not modifiable by users.
CVSS 7.5 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
algoliasearch-helper
- Versions
- ≥ 2.0.0-rc1, < 3.11.2: Affected (semver)
Update to 3.11.2
algoliasearch-helper npm
- Affected ranges
- SEMVER: ≥ 2.0.0-rc1, < 3.11.2
Update to 3.11.2