CVE-2025-32044
CVE-2025-32044 · Moodle: unauthenticated rest api user data exposure
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw has been identified in Moodle where, on certain sites, unauthenticated users could retrieve sensitive user data—including names, contact information, and hashed passwords—via stack traces returned by specific API calls. Sites with PHP configured with zend.exception_ignore_args = 1 in the php.ini file are not affected by this vulnerability.
CVSS 7.5 · High · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
moodle/moodle Packagist
- Versions
- v4.5.0
- v4.5.0-beta
- v4.5.0-rc1
- v4.5.0-rc2
- v4.5.1
- v4.5.2
- Affected ranges
- ECOSYSTEM: ≥ 4.5.0-beta, < 4.5.3
Update to 4.5.3
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published