CVE-2025-32444
CVE-2025-32444 · vLLM Vulnerable to Remote Code Execution via Mooncake Integration
This page contains facts from public vulnerability sources. Check the original advisory before updating.
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.
CVSS 10.0 · Critical · EPSS 1.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
vllm
- Versions
- >= 0.6.5, < 0.8.5: Affected
No fix published
vllm PyPI
- Versions
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- Affected ranges
- ECOSYSTEM: ≥ 0.6.5, < 0.8.5
Update to 0.8.5
vllm PyPI
- Versions
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- v0.8.4
- v0.8.3rc1
- v0.8.2
- v0.8.1
- v0.8.0rc2
- v0.8.0rc1
- v0.7.3
- v0.7.2
- v0.7.1
- v0.7.0
- v0.6.6.post1
- v0.6.6
- v0.6.5
- v0.6.4.post1
- v0.6.4
- v0.6.3.post1
- v0.6.3
- v0.6.2
- v0.6.1.post2
- v0.6.1.post1
- v0.6.1
- v0.6.0
- v0.5.5
- v0.5.4
- v0.5.3.post1
- v0.5.3
- v0.5.2
- v0.5.1
- v0.5.0.post1
- v0.5.0
- v0.4.3
- v0.4.2
- v0.4.1
- v0.4.0.post1
- v0.4.0
- v0.3.3
- v0.3.2
- v0.3.1
- v0.3.0
- v0.2.7
- v0.2.6
- v0.2.5
- v0.2.4
- v0.2.3
- v0.2.2
- v0.2.1
- v0.2.0
- v0.1.7
- v0.1.6
- v0.1.5
- v0.1.4
- v0.1.3
- v0.1.2
- v0.1.1
- v0.1.0
- submission
- Affected ranges
- GIT: < a5450f11c95847cf51a17207af9a3ca5ab569b2c
- ECOSYSTEM: ≥ 0.6.5, < 0.8.5
Update to 0.8.5
Original sources
- https://github.com/vllm-project/vllm/security/advisories/GHSA-hj4w-hm2g-p6w5
- https://github.com/vllm-project/vllm/security/advisories/GHSA-x3m8-f7g5-qhm7
- https://github.com/vllm-project/vllm/commit/a5450f11c95847cf51a17207af9a3ca5ab569b2c
- https://github.com/vllm-project/vllm/blob/32b14baf8a1f7195ca09484de3008063569b43c5/vllm/distributed/kv_transfer/kv_pipe/mooncake_pipe.py#L179
- https://nvd.nist.gov/vuln/detail/CVE-2025-32444