p PatchFirst

CVE-2025-34267

CVE-2025-34267 · Flowise Authenticated Command Execution and Sandbox Bypass via Puppeteer & Playwright Packages

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Flowise v3.0.1 < 3.0.8 and all versions after with 'ALLOW_BUILTIN_DEP' enabled contain an authenticated remote code execution vulnerability and node VM sandbox escape due to insecure use of integrated modules (Puppeteer and Playwright) within the nodevm execution environment. An authenticated attacker able to create or run a tool that leverages Puppeteer/Playwright can specify attacker-controlled browser binary paths and parameters. When the tool executes, the attacker-controlled executable/parameters are run on the host and circumvent the intended nodevm sandbox restrictions, resulting in execution of arbitrary code in the context of the host. This vulnerability was incorrectly assigned as a duplicate CVE-2025-26319 by the developers and should be considered distinct from that identifier.

CVSS 8.4 · High · EPSS 6.6% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • flowise

    Versions
    • ≥ 3.0.1, ≤ 3.0.8: Affected (semver)

    No fix published

  • flowise npm

    Affected ranges
    • SEMVER: ≥ 3.0.1, < 3.0.8

    Update to 3.0.8

Original sources

Check your server →