p PatchFirst

CVE-2025-35984

CVE-2025-35984

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A memory corruption vulnerability exists in the PCX Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When decoding the image data from a specially crafted .pcx file, a heap-based buffer overflow can occur which allows for remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.

CVSS 8.8 · High · EPSS 1.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • sail image decoding library

    Versions
    • v0.9.8: Affected

    No fix published

  • sail Debian:13

    Versions
    • 0.9.8-1
    Affected ranges
    • ECOSYSTEM: < 0.9.8-1+deb13u1

    Update to 0.9.8-1+deb13u1

  • sail Debian:14

    Versions
    • 0.9.8-1
    Affected ranges
    • ECOSYSTEM: < 0.9.9-1

    Update to 0.9.9-1

  • sail Ubuntu:24.04:LTS

    Versions
    • 0.9.0+repack-1
    • 0.9.0+repack-2
    • 0.9.0+repack-2.1
    • 0.9.0+repack-2.1build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • sail Ubuntu:25.10

    Versions
    • 0.9.7-1build1
    • 0.9.8-1
    • 0.9.9-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • sail Ubuntu:26.10

    Versions
    • 0.9.10-1
    • 0.9.10-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • sail Ubuntu:26.04:LTS

    Versions
    • 0.9.9-1
    • 0.9.10-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →