CVE-2025-3902
CVE-2025-3902 · Block Class - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-043
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Block Class allows Cross-Site Scripting (XSS).This issue affects Block Class: from 4.0.0 before 4.0.1.
CVSS 6.1 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
block class
- Versions
- ≥ 4.0.0, < 4.0.1: Affected (semver)
Update to 4.0.1
drupal/block_class Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.0.1
Update to 4.0.1