p PatchFirst

CVE-2025-40843

CVE-2025-40843 · Buffer overflow in CodeChecker log command

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CodeChecker is an analyzer tooling, defect database and viewer extension for the Clang Static Analyzer and Clang Tidy. CodeChecker versions up to 6.26.1 contain a buffer overflow vulnerability in the internal ldlogger library, which is executed by the CodeChecker log command. This issue affects CodeChecker: through 6.26.1.

CVSS 5.9 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • codechecker

    Versions
    • ≥ 0, ≤ 6.26.1: Affected (python)

    No fix published

  • codechecker PyPI

    Versions
    • 6.16.0
    • 6.16.0a1
    • 6.17.0
    • 6.18.0
    • 6.18.1
    • 6.18.2
    • 6.19.0
    • 6.19.1
    • 6.20.0
    • 6.20.0rc1
    • 6.21.0
    • 6.21.0rc1
    • 6.22.0
    • 6.22.0rc1
    • 6.22.1
    • 6.22.2
    • 6.22.2.post1
    • 6.23.0
    • 6.23.0rc2
    • 6.23.1
    • 6.24.0
    • 6.24.1
    • 6.24.2
    • 6.24.4
    • 6.25.0
    • 6.25.1
    • 6.26.0
    • 6.26.1
    Affected ranges
    • ECOSYSTEM: < 6.26.2

    Update to 6.26.2

Original sources

Check your server →