CVE-2025-4123
CVE-2025-4123
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A cross-site scripting (XSS) vulnerability exists in Grafana caused by combining a client path traversal and open redirect. This allows attackers to redirect users to a website that hosts a frontend plugin that will execute arbitrary JavaScript. This vulnerability does not require editor permissions and if anonymous access is enabled, the XSS will work. If the Grafana Image Renderer plugin is installed, it is possible to exploit the open redirect to achieve a full read SSRF. The default Content-Security-Policy (CSP) in Grafana will block the XSS though the `connect-src` directive.
CVSS 7.6 · High · EPSS 97.1% · Public exploit · Fix available
- Published
- Updated
Stack: system · applications
Affected products and versions
grafana
- Versions
- ≥ 10.4.18+security-01, < 10.4.19: Affected (semver)
- ≥ 11.2.9+security-01, < 11.2.10: Affected (semver)
- ≥ 11.3.6+security-01, < 11.3.7: Affected (semver)
- ≥ 11.4.4+security-01, < 11.4.5: Affected (semver)
- ≥ 11.5.4+security-01, < 11.5.5: Affected (semver)
- ≥ 11.6.1+security-01, < 11.6.2: Affected (semver)
- ≥ 12.0.0+security-01, < 12.0.1: Affected (semver)
Update to 10.4.19; Update to 11.2.10; Update to 11.3.7; Update to 11.4.5; Update to 11.5.5; Update to 11.6.2; Update to 12.0.1
grafana Ubuntu:16.04:LTS
- Versions
- 2.6.0+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published