p PatchFirst

CVE-2025-45769

CVE-2025-45769

This page contains facts from public vulnerability sources. Check the original advisory before updating.

php-jwt v6.11.0 was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is not meant to recommend an outcome for this CVE Record.

CVSS 6.5 · Medium · EPSS 0.1% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • firebase/php-jwt Packagist

    Versions
    • 1.0.0
    • 2.0.0
    • v2.1.0
    • v2.2.0
    • v3.0.0
    • v4.0.0
    • v5.0.0
    • v5.1.0
    • v5.2.0
    • v5.2.1
    • v5.3.0
    • v5.4.0
    • v5.5.0
    • v5.5.1
    • v6.0.0
    • v6.1.0
    • v6.1.1
    • v6.1.2
    • v6.10.0
    • v6.10.1
    • v6.10.2
    • v6.11.0
    • v6.11.1
    • v6.2.0
    • v6.3.0
    • v6.3.1
    • v6.3.2
    • v6.4.0
    • v6.5.0
    • v6.6.0
    • v6.7.0
    • v6.8.0
    • v6.8.1
    • v6.9.0
    Affected ranges
    • ECOSYSTEM: < 7.0.0

    Update to 7.0.0

Original sources

Check your server →