CVE-2025-46415
CVE-2025-46415
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A race condition in the Nix, Lix, and Guix package managers allows the removal of content from arbitrary folders. This affects Nix before 2.24.15, 2.26.4, 2.28.4, and 2.29.1; Lix before 2.91.2, 2.92.2, and 2.93.1; and Guix before 1.4.0-38.0e79d5b.
CVSS 3.2 · Low · EPSS 0.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nix
- Versions
- ≥ 0, < 2.24.15: Affected (semver)
- ≥ 2.25.0, < 2.26.4: Affected (semver)
- ≥ 2.27.0, < 2.28.4: Affected (semver)
- ≥ 2.29.0, < 2.29.1: Affected (semver)
Update to 2.24.15; Update to 2.26.4; Update to 2.28.4; Update to 2.29.1
guix Debian:11
- Versions
- 1.2.0-4
- 1.2.0-4+deb11u1
- 1.2.0-4+deb11u2
- 1.2.0-4+deb11u3
- 1.3.0+26720.a2e4e-1
- 1.3.0+26756.c07b5-1
- 1.3.0+26756.c07b5-2
- 1.3.0-1
- 1.3.0-2
- 1.3.0-3
- 1.3.0-4
- 1.3.0-5
- 1.3.0~rc1-1
- 1.4.0+154709.ab1b557d8f3-1
- 1.4.0+154710+ab1b5-1
- 1.4.0+154710+ab1b5-2
- 1.4.0+154928+f1810-1
- 1.4.0-1
- 1.4.0-2
- 1.4.0-3
- 1.4.0-4
- 1.4.0-5
- 1.4.0-6
- 1.4.0-7
- 1.4.0-8
- 1.4.0-9
- 1.4.0~rc1-1
- 1.4.0~rc1-2
- 1.4.0~rc2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
guix Ubuntu:Pro:22.04:LTS
- Versions
- 1.2.0-4
- 1.3.0-2
- 1.3.0-4
- 1.3.0-4ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
guix Ubuntu:Pro:24.04:LTS
- Versions
- 1.4.0-5
- 1.4.0-6
- 1.4.0-6build1
- 1.4.0-6ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://discourse.nixos.org/t/security-advisory-privilege-escalations-in-nix-lix-and-guix/66017
- https://lix.systems/blog/2025-06-24-lix-cves/
- https://guix.gnu.org/en/blog/2025/privilege-escalation-vulnerabilities-2025/
- https://labs.snyk.io
- https://security.snyk.io/vuln/?search=CVE-2025-46415
- https://security-tracker.debian.org/tracker/CVE-2025-46415
- https://nvd.nist.gov/vuln/detail/CVE-2025-46415