p PatchFirst

CVE-2025-46550

CVE-2025-46550 · Yeswiki Vulnerable to Unauthenticated Reflected Cross-site Scripting

This page contains facts from public vulnerability sources. Check the original advisory before updating.

YesWiki is a wiki system written in PHP. Prior to version 4.5.4, the `/?BazaR` endpoint and `idformulaire` parameter are vulnerable to cross-site scripting. An attacker can use a reflected cross-site scripting attack to steal cookies from an authenticated user by having them click on a malicious link. Stolen cookies allow the attacker to take over the user’s session. This vulnerability may also allow attackers to deface the website or embed malicious content. This issue has been patched in version 4.5.4.

CVSS 4.3 · Medium · EPSS 0.5% · Public exploit · Fix available

Published
Updated

Stack: php

Affected products and versions

  • yeswiki

    Versions
    • < 4.5.4: Affected

    No fix published

  • yeswiki/yeswiki Packagist

    Versions
    • 4.2.3
    • v4.1.0
    • v4.1.1
    • v4.1.2
    • v4.1.3
    • v4.1.4
    • v4.1.5
    • v4.2.0
    • v4.2.1
    • v4.2.2
    • v4.2.4
    • v4.3
    • v4.3.1
    • v4.4.0
    • v4.4.1
    • v4.4.2
    • v4.4.3
    • v4.4.4
    • v4.4.5
    • v4.5.0
    • v4.5.1
    • v4.5.2
    • v4.5.3
    Affected ranges
    • ECOSYSTEM: < 4.5.4

    Update to 4.5.4

Original sources

Check your server →