CVE-2025-46646
CVE-2025-46646
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Artifex Ghostscript before 10.05.0, decode_utf8 in base/gp_utf8.c mishandles overlong UTF-8 encoding. NOTE: this issue exists because of an incomplete fix for CVE-2024-46954.
CVSS 4.5 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ghostscript
- Versions
- ≥ 0, < 10.05.0: Affected (custom)
Update to 10.05.0
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 10.05.0~dfsg-1
Update to 10.05.0~dfsg-1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 10.05.0~dfsg-1
Update to 10.05.0~dfsg-1
ghostscript Ubuntu:24.04:LTS
- Versions
- 10.01.2~dfsg1-0ubuntu2
- 10.01.2~dfsg1-0ubuntu2.1
- 10.02.1~dfsg1-0ubuntu1
- 10.02.1~dfsg1-0ubuntu2
- 10.02.1~dfsg1-0ubuntu5
- 10.02.1~dfsg1-0ubuntu6
- 10.02.1~dfsg1-0ubuntu7
- 10.02.1~dfsg1-0ubuntu7.1
- 10.02.1~dfsg1-0ubuntu7.3
- 10.02.1~dfsg1-0ubuntu7.4
- 10.02.1~dfsg1-0ubuntu7.5
- Affected ranges
- ECOSYSTEM: < 10.02.1~dfsg1-0ubuntu7.6
Update to 10.02.1~dfsg1-0ubuntu7.6