p PatchFirst

CVE-2025-47705

CVE-2025-47705 · IFrame Remove Filter - Moderately critical - Cross site scripting - SA-CONTRIB-2025-051

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal IFrame Remove Filter allows Cross-Site Scripting (XSS).This issue affects IFrame Remove Filter: from 2.0.0 before 2.0.5, from 7.X-1.0 through 7.X-1.5, from 1.0 through 1.2.

CVSS 6.1 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • iframe remove filter

    Versions
    • ≥ 7.x-1.0, ≤ 7.x-1.5: Affected (custom)
    • ≥ 1.0, ≤ 1.2: Affected (semver)
    • ≥ 2.0.0, < 2.0.5: Affected (semver)

    Update to 2.0.5

  • drupal/iframeremove Packagist:https://packages.drupal.org/8

    Affected ranges
    • ECOSYSTEM: < 2.0.5

    Update to 2.0.5

Original sources

Check your server →