CVE-2025-47946
CVE-2025-47946 · symfony/ux-live-component and symfony/ux-twig-component vulnerable to unsanitized HTML attribute injection via ComponentAttributes
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Symfony UX is an initiative and set of libraries to integrate JavaScript tools into applications. Prior to version 2.25.1, rendering `{{ attributes }}` or using any method that returns a `ComponentAttributes` instance (e.g. `only()`, `defaults()`, `without()`) ouputs attribute values directly without escaping. If these values are unsafe (e.g. contain user input), this can lead to HTML attribute injection and XSS vulnerabilities. The issue is fixed in version `2.25.1` of `symfony/ux-twig-component` Those who use `symfony/ux-live-component` must also update it to `2.25.1` to benefit from the fix, as it reuses the `ComponentAttributes` class internally. As a workaround, avoid rendering `{{ attributes }}` or derived objects directly if it may contain untrusted values. Instead, use `{{ attributes.render('name') }}` for safe output of individual attributes.
CVSS 6.1 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
ux
- Versions
- < 2.25.1: Affected
No fix published
symfony/ux-twig-component Packagist
- Versions
- v2.0.0
- v2.0.1
- v2.1.0
- v2.1.1
- v2.10.0
- v2.11.0
- v2.11.1
- v2.11.2
- v2.12.0
- v2.13.0
- v2.13.1
- v2.13.3
- v2.14.0
- v2.14.2
- v2.15.0
- v2.16.0
- v2.17.0
- v2.18.0
- v2.18.1
- v2.19.0
- v2.19.2
- v2.2.0
- v2.20.0
- v2.21.0
- v2.22.0
- v2.22.1
- v2.23.0
- v2.24.0
- v2.25.0
- v2.3.0
- v2.4.0
- v2.5.0
- v2.6.0
- v2.6.1
- v2.7.0
- v2.7.1
- v2.8.0
- v2.8.1
- v2.9.0
- v2.9.1
- v2.9.2
- Affected ranges
- ECOSYSTEM: < 2.25.1
Update to 2.25.1
symfony/ux-live-component Packagist
- Versions
- v2.0.0
- v2.0.1
- v2.1.0
- v2.1.1
- v2.10.0
- v2.11.0
- v2.11.1
- v2.11.2
- v2.12.0
- v2.13.0
- v2.13.1
- v2.13.2
- v2.13.3
- v2.14.0
- v2.14.1
- v2.14.2
- v2.15.0
- v2.16.0
- v2.17.0
- v2.18.0
- v2.18.1
- v2.19.0
- v2.19.2
- v2.2.0
- v2.20.0
- v2.21.0
- v2.22.0
- v2.22.1
- v2.23.0
- v2.24.0
- v2.25.0
- v2.3.0
- v2.4.0
- v2.5.0
- v2.6.0
- v2.6.1
- v2.7.0
- v2.7.1
- v2.8.0
- v2.8.1
- v2.9.0
- v2.9.1
- Affected ranges
- ECOSYSTEM: < 2.25.1
Update to 2.25.1