CVE-2025-48796
CVE-2025-48796 · Gimp: stack-based buffer overflows in file-ico
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in GIMP. The GIMP ani_load_image() function is vulnerable to a stack-based overflow. If a user opens.ANI files, GIMP may be used to store more information than the capacity allows. This flaw allows a malicious ANI file to trigger arbitrary code execution.
CVSS 7.3 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
red hat enterprise linux 6
No fix published
red hat enterprise linux 7
No fix published
red hat enterprise linux 8
No fix published
red hat enterprise linux 9
No fix published
gimp Debian:13
- Affected ranges
- ECOSYSTEM: < 3.0.0~RC1-4
Update to 3.0.0~RC1-4
gimp Debian:14
- Affected ranges
- ECOSYSTEM: < 3.0.0~RC1-4
Update to 3.0.0~RC1-4