CVE-2025-48887
CVE-2025-48887 · vLLM has a Regular Expression Denial of Service (ReDoS, Exponential Complexity) Vulnerability in `pythonic_tool_parser.py`
This page contains facts from public vulnerability sources. Check the original advisory before updating.
vLLM, an inference and serving engine for large language models (LLMs), has a Regular Expression Denial of Service (ReDoS) vulnerability in the file `vllm/entrypoints/openai/tool_parsers/pythonic_tool_parser.py` of versions 0.6.4 up to but excluding 0.9.0. The root cause is the use of a highly complex and nested regular expression for tool call detection, which can be exploited by an attacker to cause severe performance degradation or make the service unavailable. The pattern contains multiple nested quantifiers, optional groups, and inner repetitions which make it vulnerable to catastrophic backtracking. Version 0.9.0 contains a patch for the issue.
CVSS 6.5 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
vllm
- Versions
- >= 0.6.4, < 0.9.0: Affected
No fix published
vllm PyPI
- Versions
- 0.6.4
- 0.6.4.post1
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.5.post1
- Affected ranges
- ECOSYSTEM: ≥ 0.6.4, < 0.9.0
Update to 0.9.0
vllm PyPI
- Versions
- 0.6.4
- 0.6.4.post1
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.5.post1
- v0.8.4
- v0.8.3rc1
- v0.8.2
- v0.8.1
- v0.8.0rc2
- v0.8.0rc1
- v0.7.3
- v0.7.2
- v0.7.1
- v0.7.0
- v0.6.6.post1
- v0.6.6
- v0.6.5
- v0.6.4.post1
- v0.6.4
- v0.6.3.post1
- v0.6.3
- v0.6.2
- v0.6.1.post2
- v0.6.1.post1
- v0.6.1
- v0.6.0
- v0.5.5
- v0.5.4
- v0.5.3.post1
- v0.5.3
- v0.5.2
- v0.5.1
- v0.5.0.post1
- v0.5.0
- v0.4.3
- v0.4.2
- v0.4.1
- v0.4.0.post1
- v0.4.0
- v0.3.3
- v0.3.2
- v0.3.1
- v0.3.0
- v0.2.7
- v0.2.6
- v0.2.5
- v0.2.4
- v0.2.3
- v0.2.2
- v0.2.1
- v0.2.0
- v0.1.7
- v0.1.6
- v0.1.5
- v0.1.4
- v0.1.3
- v0.1.2
- v0.1.1
- v0.1.0
- submission
- Affected ranges
- GIT: < 4fc1bf813ad80172c1db31264beaef7d93fe0601
- ECOSYSTEM: ≥ 0.6.4, < 0.9.0
Update to 0.9.0