p PatchFirst

CVE-2025-48943

CVE-2025-48943 · vLLM allows clients to crash the openai server with invalid regex

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vLLM is an inference and serving engine for large language models (LLMs). Version 0.8.0 up to but excluding 0.9.0 have a Denial of Service (ReDoS) that causes the vLLM server to crash if an invalid regex was provided while using structured output. This vulnerability is similar to GHSA-6qc9-v4r8-22xg/CVE-2025-48942, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.

CVSS 6.5 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm

    Versions
    • >= 0.8.0, < 0.9.0: Affected

    No fix published

  • vllm PyPI

    Versions
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.5.post1
    Affected ranges
    • ECOSYSTEM: ≥ 0.8.0, < 0.9.0

    Update to 0.9.0

  • vllm PyPI

    Versions
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.5.post1
    Affected ranges
    • GIT: < 08bf7840780980c7568c573c70a6a8db94fd45ff
    • ECOSYSTEM: ≥ 0.8.0, < 0.9.0

    Update to 0.9.0

Original sources

Check your server →