p PatchFirst

CVE-2025-48944

CVE-2025-48944 · vLLM Tool Schema allows DoS via Malformed pattern and type Fields

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vLLM is an inference and serving engine for large language models (LLMs). In version 0.8.0 up to but excluding 0.9.0, the vLLM backend used with the /v1/chat/completions OpenAPI endpoint fails to validate unexpected or malformed input in the "pattern" and "type" fields when the tools functionality is invoked. These inputs are not validated before being compiled or parsed, causing a crash of the inference worker with a single request. The worker will remain down until it is restarted. Version 0.9.0 fixes the issue.

CVSS 6.5 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm

    Versions
    • >= 0.8.0, < 0.9.0: Affected

    No fix published

  • vllm PyPI

    Versions
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.5.post1
    Affected ranges
    • ECOSYSTEM: ≥ 0.8.0, < 0.9.0

    Update to 0.9.0

Original sources

Check your server →