p PatchFirst

CVE-2025-48951

CVE-2025-48951 · Auth0-PHP SDK Deserialization of Untrusted Data vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.

CVSS 9.3 · Critical · EPSS 0.8% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • auth0-php

    Versions
    • >= 8.0.0-BETA3, < 8.3.1: Affected

    No fix published

  • auth0/auth0-php Packagist

    Versions
    • 8.0.0
    • 8.0.0-BETA3
    • 8.0.1
    • 8.0.2
    • 8.0.3
    • 8.0.4
    • 8.0.5
    • 8.0.6
    • 8.1.0
    • 8.2.0
    • 8.2.1
    • 8.3.0
    Affected ranges
    • ECOSYSTEM: ≥ 8.0.0-BETA3, < 8.3.1

    Update to 8.3.1

Original sources

Check your server →