CVE-2025-49137
CVE-2025-49137 · Hax CMS Stored Cross-Site Scripting vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, the application does not sufficiently sanitize user input, allowing for the execution of arbitrary JavaScript code. The 'saveNode' and 'saveManifest' endpoints take user input and store it in the JSON schema for the site. This content is then rendered in the generated HAX site. Although the application does not allow users to supply a `script` tag, it does allow the use of other HTML tags to run JavaScript. Version 11.0.0 fixes the issue.
CVSS 8.5 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
issues
- Versions
- < 11.0.0: Affected
No fix published
elmsln/haxcms Packagist
- Versions
- 0.0.1
- 0.1.0
- 0.11.0
- 0.12.0
- 0.12.1
- 0.12.2
- 0.12.3
- 0.2.0
- 0.3.0
- 0.4.0
- 0.5.0
- 0.6.0
- 0.7.0
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.0
- Affected ranges
- ECOSYSTEM: < 11.0.0
Update to 11.0.0