CVE-2025-49596
CVE-2025-49596 · MCP Inspector proxy server lacks authentication between the Inspector client and proxy
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
CVSS 9.4 · Critical · EPSS 44.5% · Public exploit · Fix available
- Published
- Updated
Stack: node
Affected products and versions
inspector
- Versions
- < 0.14.1: Affected
No fix published
@modelcontextprotocol/inspector npm
- Affected ranges
- SEMVER: < 0.14.1
Update to 0.14.1
Original sources
- https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-7f8r-222p-6f5g
- https://github.com/modelcontextprotocol/inspector/commit/50df0e1ec488f3983740b4d28d2a968f12eb8979
- https://thenewstack.io/mcp-vulnerability-exposes-the-ai-untrusted-code-crisis
- https://www.oligo.security/blog/critical-rce-vulnerability-in-anthropic-mcp-inspector-cve-2025-49596
- https://nvd.nist.gov/vuln/detail/CVE-2025-49596