p PatchFirst

CVE-2025-4976

CVE-2025-4976 · Exposure of Sensitive Information Due to Incompatible Policies in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab EE affecting all versions from 17.0 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that, under certain circumstances, could have allowed an attacker to access internal notes in GitLab Duo responses.

CVSS 4.3 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 17.0, < 18.0.5: Affected (semver)
    • ≥ 18.1, < 18.1.3: Affected (semver)
    • ≥ 18.2, < 18.2.1: Affected (semver)

    Update to 18.0.5; Update to 18.1.3; Update to 18.2.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →