CVE-2025-50183
CVE-2025-50183 · OpenList (frontend) allows XSS Attacks in the built-in Markdown Viewer
This page contains facts from public vulnerability sources. Check the original advisory before updating.
OpenList Frontend is a UI component for OpenList. Prior to version 4.0.0-rc.4, a vulnerability exists in the file preview/browsing feature of the application, where files with a .py extension that contain JavaScript code wrapped in <script> tags may be interpreted and executed as HTML in certain modes. This leads to a stored XSS vulnerability. This issue has been patched in version 4.0.0-rc.4.
CVSS 6.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
openlist
- Versions
- < 4.0.0-rc.4: Affected
No fix published
@openlist-frontend/openlist-frontend npm
- Affected ranges
- SEMVER: < 4.0.0-rc.4
Update to 4.0.0-rc.4