CVE-2025-50460
CVE-2025-50460
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A remote code execution (RCE) vulnerability exists in the ms-swift project version 3.3.0 due to unsafe deserialization in tests/run.py using yaml.load() from the PyYAML library (versions = 5.3.1). If an attacker can control the content of the YAML configuration file passed to the --run_config parameter, arbitrary code can be executed during deserialization. This can lead to full system compromise. The vulnerability is triggered when a malicious YAML file is loaded, allowing the execution of arbitrary Python commands such as os.system(). It is recommended to upgrade PyYAML to version 5.4 or higher, and to use yaml.safe_load() to mitigate the issue.
CVSS 9.8 · Critical · EPSS 2.7%
- Published
- Updated
Stack: python
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ms-swift PyPI
- Versions
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.3.post1
- 2.0.4
- 2.0.5
- 2.0.5.post1
- 2.1.0
- 2.1.1
- 2.1.1.post1
- 2.1.1.post2
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.3.0
- 2.3.0.post1
- 2.3.1
- 2.3.2
- 2.3.2.post1
- 2.4.0
- 2.4.0.post1
- 2.4.1
- 2.4.2
- 2.4.2.post1
- 2.4.2.post2
- 2.5.0.post1
- 2.5.1
- 2.5.1.post1
- 2.5.2
- 2.5.2.post1
- 2.6.0
- 2.6.0.post1
- 2.6.0.post2
- 2.6.1
- 3.0.0
- 3.0.1
- 3.0.1.post1
- 3.0.2
- 3.0.2.post1
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.1.post1
- 3.2.0
- 3.2.0.post2
- 3.2.1
- 3.2.2
- 3.3.0
- 3.3.0.post1
- 3.3.1
- 3.4.0
- 3.4.1
- 3.4.1.post1
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.6.0
- 3.6.1
- 3.6.2
- 3.6.3
- Affected ranges
- ECOSYSTEM: ≤ 3.6.3
No fix published