CVE-2025-51427
CVE-2025-51427
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in ModelScope 1.25.0 allowing attackers to execute arbitrary code via crafted module listed in the configuration file (dey_mini.yaml) under the key ['nnet']['module'].
CVSS 7.3 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
modelscope PyPI
- Versions
- 1.0.4
- 1.1.1
- 1.1.3
- 1.10.0
- 1.11.0
- 1.11.1
- 1.12.0
- 1.13.0
- 1.13.1
- 1.13.2
- 1.13.3
- 1.14.0
- 1.15.0
- 1.16.0
- 1.16.1
- 1.17.0
- 1.17.1
- 1.18.0
- 1.18.1
- 1.19.0
- 1.19.1
- 1.19.2
- 1.2.0
- 1.2.1
- 1.20.0
- 1.20.1
- 1.21.0
- 1.21.1
- 1.22.0
- 1.22.1
- 1.22.2
- 1.22.3
- 1.23.0
- 1.23.1
- 1.23.2
- 1.24.0
- 1.24.1
- 1.25.0
- 1.26.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.6.0
- 1.6.1
- 1.7.0
- 1.7.1
- 1.8.0
- 1.8.0rc0
- 1.8.1
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- Affected ranges
- ECOSYSTEM: < 1.27.0
Update to 1.27.0
Original sources
- https://github.com/modelscope/modelscope/issues/1331
- https://github.com/modelscope/modelscope/pull/1333
- https://github.com/JIRUWOZHI/vulnerability-disclosure/blob/main/CVE-2025-51427/CVE_2025_51427.md
- https://access.redhat.com/security/cve/CVE-2025-51427
- https://bugzilla.redhat.com/show_bug.cgi?id=2479894
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-51427.json
- https://nvd.nist.gov/vuln/detail/CVE-2025-51427