p PatchFirst

CVE-2025-5174

CVE-2025-5174 · erdogant pypickle pypickle.py load deserialization

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

CVSS 4.8 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • pypickle

    Versions
    • 1.1.0: Affected
    • 1.1.1: Affected
    • 1.1.2: Affected
    • 1.1.3: Affected
    • 1.1.4: Affected
    • 1.1.5: Affected

    No fix published

  • pypickle PyPI

    Versions
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    Affected ranges
    • ECOSYSTEM: < 2.0.0

    Update to 2.0.0

  • pypickle PyPI

    Versions
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.2
    Affected ranges
    • {"events": [{"introduced": "0"}, {"fixed": "14b4cae704a0bb4eb6723e238f25382d847a1917"}, {"fixed": "5058ea8c0666b3f8d30893be5c0132ad7fb7bf39"}], "repo": "https://github.com/erdogant/pypickle", "type": "GIT"}
    • ECOSYSTEM: < 2.0.0

    Update to 2.0.0

Original sources

Check your server →