p PatchFirst

CVE-2025-53092

CVE-2025-53092 · Strapi core vulnerable to sensitive data exposure via CORS misconfiguration

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Strapi is an open source headless content management system. Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. This allows an attacker-controlled site to send credentialed requests to the Strapi backend. An attacker can exploit this by hosting a malicious site on a different origin (e.g., different port) and sending requests with credentials to the Strapi API. The vulnerability is fixed in version 5.20.0. No known workarounds exist.

CVSS 6.5 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • strapi

    Versions
    • < 5.20.0: Affected

    No fix published

  • @strapi/core npm

    Affected ranges
    • SEMVER: < 5.20.0

    Update to 5.20.0

Original sources

Check your server →