CVE-2025-53366
CVE-2025-53366 · MCP SDK Vulnerable to FastMCP Server Validation Error, Leading to Denial of Service
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The MCP Python SDK, called `mcp` on PyPI, is a Python implementation of the Model Context Protocol (MCP). Prior to version 1.9.4, a validation error in the MCP SDK can cause an unhandled exception when processing malformed requests, resulting in service unavailability (500 errors) until manually restarted. Impact may vary depending on the deployment conditions, and presence of infrastructure-level resilience measures. Version 1.9.4 contains a patch for the issue.
CVSS 8.7 · High · EPSS 9.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
python-sdk
- Versions
- < 1.9.4: Affected
No fix published
mcp PyPI
- Versions
- 0.9.1
- 1.0.0
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.2.0
- 1.2.0rc1
- 1.2.1
- 1.3.0
- 1.3.0rc1
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.8.1
- 1.9.0
- 1.9.1
- 1.9.2
- 1.9.3
- Affected ranges
- ECOSYSTEM: < 1.9.4
Update to 1.9.4