CVE-2025-54119
CVE-2025-54119 · ADOdb's sqlite3 driver allows SQL injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. In versions 5.22.9 and below, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a sqlite3 database and calls the metaColumns(), metaForeignKeys() or metaIndexes() methods with a crafted table name. This is fixed in version 5.22.10. To workaround this issue, only pass controlled data to metaColumns(), metaForeignKeys() and metaIndexes() method's $table parameter.
CVSS 10.0 · Critical · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
adodb
- Versions
- < 5.22.10: Affected
No fix published
libphp-adodb Debian:12
- Versions
- 5.21.4-1
- 5.21.4-1+deb12u1
- Affected ranges
- ECOSYSTEM: < 5.21.4-1+deb12u2
Update to 5.21.4-1+deb12u2
libphp-adodb Debian:13
- Versions
- 5.22.9-0.1
- Affected ranges
- ECOSYSTEM: < 5.22.9-0.1+deb13u1
Update to 5.22.9-0.1+deb13u1
libphp-adodb Debian:14
- Versions
- 5.22.9-0.1
- Affected ranges
- ECOSYSTEM: < 5.22.10-0.1
Update to 5.22.10-0.1
adodb/adodb-php Packagist
- Versions
- v5.19
- v5.20.0
- v5.20.1
- v5.20.10
- v5.20.11
- v5.20.12
- v5.20.13
- v5.20.14
- v5.20.15
- v5.20.16
- v5.20.17
- v5.20.18
- v5.20.19
- v5.20.2
- v5.20.20
- v5.20.21
- v5.20.3
- v5.20.4
- v5.20.5
- v5.20.6
- v5.20.7
- v5.20.8
- v5.20.9
- v5.21.0
- v5.21.0-beta.1
- v5.21.0-rc.1
- v5.21.1
- v5.21.2
- v5.21.3
- v5.21.4
- v5.22.0
- v5.22.1
- v5.22.2
- v5.22.3
- v5.22.4
- v5.22.5
- v5.22.6
- v5.22.7
- v5.22.8
- v5.22.9
- Affected ranges
- ECOSYSTEM: < 5.22.10
Update to 5.22.10
libphp-adodb Ubuntu:Pro:16.04:LTS
- Versions
- 5.18a-1
- 5.20.1-1
- 5.20.2-1
- 5.20.2-2
- 5.20.3-1
- 5.20.3-1ubuntu1
- 5.20.3-1ubuntu1+esm1
- 5.20.3-1ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libphp-adodb Ubuntu:Pro:18.04:LTS
- Versions
- 5.20.9-1
- 5.20.9-1ubuntu0.1~esm1
- 5.20.9-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libphp-adodb Ubuntu:Pro:20.04:LTS
- Versions
- 5.20.14-1
- 5.20.15-1
- 5.20.16-1
- 5.20.16-1ubuntu0.1~esm1
- 5.20.16-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libphp-adodb Ubuntu:Pro:22.04:LTS
- Versions
- 5.20.19-1
- 5.20.19-1ubuntu0.1
- 5.20.19-1ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libphp-adodb Ubuntu:Pro:24.04:LTS
- Versions
- 5.21.4-1
- 5.21.4-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libphp-adodb Ubuntu:25.10
- Versions
- 5.22.8-0.1
- 5.22.9-0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libphp-adodb Ubuntu:26.10
- Versions
- 5.22.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libphp-adodb Ubuntu:26.04:LTS
- Versions
- 5.22.9-0.1
- 5.22.10-0.1
- 5.22.10-1
- 5.22.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/ADOdb/ADOdb/security/advisories/GHSA-vf2r-cxg9-p7rf
- https://github.com/ADOdb/ADOdb/issues/1083
- https://github.com/ADOdb/ADOdb/commit/5b8bd52cdcffefb4ecded1b399c98cfa516afe03
- https://lists.debian.org/debian-lts-announce/2025/10/msg00020.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-54119