CVE-2025-54365
CVE-2025-54365 · fastapi-guard patch contains bypassable RegEx
This page contains facts from public vulnerability sources. Check the original advisory before updating.
fastapi-guard is a security library for FastAPI that provides middleware to control IPs, log requests, detect penetration attempts and more. In version 3.0.1, the regular expression patched to mitigate the ReDoS vulnerability by limiting the length of string fails to catch inputs that exceed this limit. This type of patch fails to detect cases in which the string representing the attributes of a <script> tag exceeds 100 characters. As a result, most of the regex patterns present in version 3.0.1 can be bypassed. This is fixed in version 3.0.2.
CVSS 7.8 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
fastapi-guard
- Versions
- >= 3.0.1, < 3.0.2: Affected
No fix published
fastapi-guard PyPI
- Versions
- 3.0.1
- Affected ranges
- ECOSYSTEM: ≥ 3.0.1, < 3.0.2
Update to 3.0.2
Original sources
- https://github.com/rennf93/fastapi-guard/security/advisories/GHSA-rrf6-pxg8-684g
- https://github.com/rennf93/fastapi-guard/commit/0829292c322d33dc14ab00c5451c5c138148035a
- https://github.com/rennf93/fastapi-guard/commit/d9d50e8130b7b434cdc1b001b8cfd03a06729f7f
- https://nvd.nist.gov/vuln/detail/CVE-2025-54365