CVE-2025-54419
CVE-2025-54419 · Node-SAML Contains SAML Signature Verification Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A SAML library not dependent on any frameworks that runs in Node. In version 5.0.1, Node-SAML loads the assertion from the (unsigned) original response document. This is different than the parts that are verified when checking signature. This allows an attacker to modify authentication details within a valid SAML assertion. For example, in one attack it is possible to remove any character from the SAML assertion username. To conduct the attack an attacker would need a validly signed document from the identity provider (IdP). This is fixed in version 5.1.0.
CVSS 10.0 · Critical · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
node-saml
- Versions
- = 5.0.1: Affected
No fix published
@node-saml/node-saml npm
- Affected ranges
- SEMVER: < 5.1.0
Update to 5.1.0
passport-saml npm
- Affected ranges
- SEMVER: ≤ 3.2.4
No fix published
@node-saml/passport-saml npm
- Affected ranges
- SEMVER: < 5.1.0
Update to 5.1.0