p PatchFirst

CVE-2025-54951

CVE-2025-54951

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A group of related buffer overflow vulnerabilities in the loading of ExecuTorch models can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit cea9b23aa8ff78aff92829a466da97461cc7930c.

CVSS 9.8 · Critical · EPSS 0.7% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • executorch

    Versions
    • ≥ 0, < https://github.com/pytorch/executorch/commit/cea9b23aa8ff78aff92829a466da97461cc7930c: Affected (git)

    No fix published

  • executorch PyPI

    Versions
    • 0.1.0
    • 0.1.2
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.6.0
    Affected ranges
    • ECOSYSTEM: < 0.7.0

    Update to 0.7.0

  • org.pytorch:executorch-android Maven

    Versions
    • 0.5.0
    • 0.5.1
    • 0.6.0
    • 0.6.0-rc1
    • 0.6.0-rc3
    • 0.6.0-rc4
    • 0.6.0-rc6
    • 0.7.0-rc1
    • 0.7.0-rc2
    • 0.7.0-rc5
    Affected ranges
    • ECOSYSTEM: < 0.7.0

    Update to 0.7.0

  • github.com/pytorch/executorch SwiftURL

    Affected ranges
    • SEMVER: < 0.7.0

    Update to 0.7.0

Original sources

Check your server →