CVE-2025-54994
CVE-2025-54994 · @akoskm/create-mcp-server-stdio has Command Injection in MCP Server due to unsafe `exec` API
This page contains facts from public vulnerability sources. Check the original advisory before updating.
@akoskm/create-mcp-server-stdio is an MCP server starter kit that uses the StdioServerTransport. Prior to version 0.0.13, the MCP Server is written in a way that is vulnerable to command injection vulnerability attacks as part of some of its MCP Server tool definition and implementation. The MCP Server exposes the tool `which-app-on-port` which relies on Node.js child process API `exec` which is an unsafe and vulnerable API if concatenated with untrusted user input. Version 0.0.13 contains a fix for the issue.
CVSS 9.3 · Critical · EPSS 1.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
create-mcp-server-stdio
- Versions
- < 0.0.13: Affected
No fix published
@akoskm/create-mcp-server-stdio npm
- Affected ranges
- SEMVER: < 0.0.13
Update to 0.0.13
Original sources
- https://github.com/akoskm/create-mcp-server-stdio/security/advisories/GHSA-3ch2-jxxc-v4xf
- https://github.com/akoskm/create-mcp-server-stdio/commit/48c26bbe1f8c62764e4592f33c8300d1cadd2eac
- https://github.com/akoskm/create-mcp-server-stdio/blob/main/src/index.ts#L24-L40
- https://nvd.nist.gov/vuln/detail/CVE-2025-54994