CVE-2025-55197
CVE-2025-55197 · pypdf's Manipulated FlateDecode streams can exhaust RAM
This page contains facts from public vulnerability sources. Check the original advisory before updating.
pypdf is a free and open-source pure-python PDF library. Prior to version 6.0.0, an attacker can craft a PDF which leads to the RAM being exhausted. This requires just reading the file if a series of FlateDecode filters is used on a malicious cross-reference stream. Other content streams are affected on explicit access. This issue has been fixed in 6.0.0. If an update is not possible, a workaround involves including the fixed code from pypdf.filters.decompress into the existing filters file.
CVSS 6.6 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
pypdf
- Versions
- < 6.0.0: Affected
No fix published
pypdf Debian:12
- Versions
- 3.17.4-1
- 3.4.1-1
- 3.4.1-1+deb12u1
- 4.0.0-1
- 4.0.0-1~exp1
- 4.0.1-1
- 4.0.2-1
- 4.1.0-1
- 4.2.0-1
- 4.3.1-1
- 5.4.0-1
- 6.9.0-1
- 6.9.2-1
- 6.9.2-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf Debian:13
- Versions
- 5.4.0-1
- 6.9.0-1
- 6.9.2-1
- 6.9.2-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf Debian:14
- Versions
- 5.4.0-1
- Affected ranges
- ECOSYSTEM: < 6.9.0-1
Update to 6.9.0-1
pypdf2 Debian:12
- Versions
- 2.12.1-3
- 2.12.1-3+deb12u1
- 2.12.1-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf PyPI
- Versions
- 1.0
- 1.1
- 1.10
- 1.11
- 1.12
- 1.13
- 1.2
- 1.3
- 1.4
- 1.5
- 1.6
- 1.7
- 1.8
- 1.9
- 3.1.0
- 3.10.0
- 3.11.0
- 3.11.1
- 3.12.0
- 3.12.1
- 3.12.2
- 3.13.0
- 3.14.0
- 3.15.0
- 3.15.1
- 3.15.2
- 3.15.3
- 3.15.4
- 3.15.5
- 3.16.0
- 3.16.1
- 3.16.2
- 3.16.3
- 3.16.4
- 3.17.0
- 3.17.1
- 3.17.2
- 3.17.3
- 3.17.4
- 3.2.0
- 3.2.1
- 3.3.0
- 3.4.0
- 3.4.1
- 3.5.0
- 3.5.1
- 3.5.2
- 3.6.0
- 3.7.0
- 3.7.1
- 3.8.0
- 3.8.1
- 3.9.0
- 3.9.1
- 4.0.0
- 4.0.1
- 4.0.2
- 4.1.0
- 4.2.0
- 4.3.0
- 4.3.1
- 5.0.0
- 5.0.1
- 5.1.0
- 5.2.0
- 5.3.0
- 5.3.1
- 5.4.0
- 5.5.0
- 5.6.0
- 5.6.1
- 5.7.0
- 5.8.0
- 5.9.0
- Affected ranges
- ECOSYSTEM: < 6.0.0
Update to 6.0.0
pypdf2 Ubuntu:Pro:16.04:LTS
- Versions
- 1.23+git20141008-1
- 1.25.1-1
- 1.25.1-1ubuntu0.1~esm1
- 1.25.1-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf2 Ubuntu:Pro:18.04:LTS
- Versions
- 1.26.0-2
- 1.26.0-2ubuntu0.1~esm1
- 1.26.0-2ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf2 Ubuntu:20.04:LTS
- Versions
- 1.26.0-2
- 1.26.0-3ubuntu1
- 1.26.0-3ubuntu1.20.04.1
- 1.26.0-3ubuntu1.20.04.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf2 Ubuntu:22.04:LTS
- Versions
- 1.26.0-4
- 1.26.0-4ubuntu0.22.04.1
- 1.26.0-4ubuntu0.22.04.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf Ubuntu:24.04:LTS
- Versions
- 3.4.1-1
- 3.17.4-1
- 4.0.0-1
- 4.0.1-1
- 4.0.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf2 Ubuntu:24.04:LTS
- Versions
- 2.12.1-3
- 2.12.1-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf Ubuntu:25.10
- Versions
- 4.3.1-1
- 5.4.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf Ubuntu:26.10
- Versions
- 6.9.2-1
- 6.9.2-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pypdf Ubuntu:26.04:LTS
- Versions
- 5.4.0-1
- 6.9.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/py-pdf/pypdf/security/advisories/GHSA-7hfw-26vp-jp8m
- https://github.com/py-pdf/pypdf/issues/3429
- https://github.com/py-pdf/pypdf/pull/3430
- https://github.com/py-pdf/pypdf/blob/0dd57738bbdcdb63f0fb43d8a6b3d222b6946595/pypdf/filters.py#L72-L143
- https://github.com/py-pdf/pypdf/releases/tag/6.0.0
- https://nvd.nist.gov/vuln/detail/CVE-2025-55197