CVE-2025-58444
CVE-2025-58444 · MCP Inspector is Vulnerable to Potential Command Execution via XSS When Connecting to an Untrusted MCP Server
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The MCP inspector is a developer tool for testing and debugging MCP servers. A cross-site scripting issue was reported in versions of the MCP Inspector local development tool prior to 0.16.6 when connecting to untrusted remote MCP servers with a malicious redirect URI. This could be leveraged to interact directly with the inspector proxy to trigger arbitrary command execution. Users are advised to update to 0.16.6 to resolve this issue.
CVSS 8.6 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
inspector
- Versions
- < 0.16.6: Affected
No fix published
@modelcontextprotocol/inspector npm
- Affected ranges
- SEMVER: < 0.16.6
Update to 0.16.6